Problema con NVidia al actualizar feisty

Al hacer un apt-get upgrade con las actualizaciones de feisty o sorpresame di cuenta que de hay un bug con restricted modules y te instala una version del modulo totalmente incompatible con la del X11.

Osea la version del modulo difier del paquete nvidia-glx

Tonces instale el nvidia-glx-source

lo recompile para crear un paquete .deb

KSRC=/usr/src/linux KVERS=2.6.20-16-generic debian/rules kdist_image

luego lo instale, pero tuve que tocar un par de archivos. como el mtab.sh en init.d

<code>

# S07linux-restricted-modules-common
exec 9<&0 0</proc/mounts
while read FDEV FDIR FTYPE FOPTS REST
do
case “$FDIR” in
))
# /lib/modules/*/volatile)
# domtab “$FTYPE” “$FDIR” “lrm”
;;
esac
</code>

y en el init de module-init-tools, ya que el modprobe tiraba error al querer cargar el modulo nvidia
insmod /lib/modules/2.6.20-16-generic/nvidia/nvidia.ko

exit 0

en fin eso para solucionar un bug feo y engorroso que no permite q tengas X :p

pero ahora tengo otro problema la gnome-terminal se me ve toda en blanco :s

espero que mejoren la calidad de actualizaciones los de ubuntu :p

Seguime :